~roshless/PKGBUILDs

c2b7a8d0617f4cc418eaf7ac57248f7b442950ab — Roshless 18 days ago 51c82f1
upgpkg: lagrange 1.7.0-1

upstream release
3 files changed, 10 insertions(+), 4 deletions(-)

M lagrange/.SRCINFO
M lagrange/PKGBUILD
M lagrange/lagrange.install
M lagrange/.SRCINFO => lagrange/.SRCINFO +3 -3
@@ 1,6 1,6 @@
pkgbase = lagrange
	pkgdesc = Beautiful Gemini Client
	pkgver = 1.6.5
	pkgver = 1.7.0
	pkgrel = 1
	url = https://git.skyjake.fi/skyjake/lagrange
	install = lagrange.install


@@ 18,7 18,7 @@ pkgbase = lagrange
	depends = pcre
	depends = sdl2
	optdepends = mpg123
	source = https://git.skyjake.fi/skyjake/lagrange/releases/download/v1.6.5/lagrange-1.6.5.tar.gz
	sha256sums = c971850414aefad2e5f38659c173cdc2f765bfcf158a32c84b5c61294558b00f
	source = https://git.skyjake.fi/skyjake/lagrange/releases/download/v1.7.0/lagrange-1.7.0.tar.gz
	sha256sums = ad1a0b9b4e368882faba8ed0e6c90b27c944a6a0b3ba49360fa8be75e6f5b79e

pkgname = lagrange

M lagrange/PKGBUILD => lagrange/PKGBUILD +1 -1
@@ 2,7 2,7 @@

pkgname=lagrange
pkgrel=1
pkgver=1.6.5
pkgver=1.7.0
pkgdesc="Beautiful Gemini Client"
url="https://git.skyjake.fi/skyjake/lagrange"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')

M lagrange/lagrange.install => lagrange/lagrange.install +6 -0
@@ 5,5 5,11 @@ post_upgrade() {
	echo "A new TOFU trust store will be created. The old one is kept around but ignored."
	echo "App state serialization format has been updated. Downgrading to a previous release will cause app state to be reset (e.g., tabs closed, navigation history cleared)."
	echo ""
    elif [[ $1 = 1.7.0-1 ]]; then
	echo ""
	echo "Notes for update 1.7.0:"
	echo "Bookmarks file format has changed. Your existing bookmarks will be imported to the new format. The old bookmarks.txt file can be found in the config directory and is writable only by v1.6 and earlier versions."
	echo" Saved UI state format has changed. Downgrading will reset window state, close all tabs, and clear the navigation cache."
	echo ""
    fi
}